Warum funktionieren einige Salesforce-Integrationen nur mit bestimmten Versionen von Salesforce?

Wenn Sie unter Integrationen Salesforce-Apps in AppExchange verstehen, ist dies darauf zurückzuführen, dass für eine App eine bestimmte Funktion erforderlich ist, die in dieser Salesforce-Edition nicht enthalten ist.

Beispielsweise erfordert meine App @ www.appfrontier.com / chargent.html, dass Scheduled Apex den täglichen Stapel ausführt. Diese Funktion ist nur in der Enterprise Edition und höher von Salesforce verfügbar. Es gibt eine Reihe weiterer Funktionen, die wir ebenfalls verwenden und die in der Professional Edition nicht verfügbar sind. Einige können jedoch à la carte erworben werden (z. B. Workflow-Regeln).

Mit Salesforce können Partneranwendungen in AppExchange mithilfe der Salesforce-APIs mit Professional und Group Edition interagieren, die keinen API-Zugriff enthalten. Wenn jedoch andere fehlende Funktionen in einer App verwendet werden, verhindert dies leider die Installation der App in Salesforce.

Aus diesem Grund funktionieren in der Salesforce Group Edition nur sehr wenige Apps, da so viele Funktionen “entfernt” wurden.